Solving “unsupported locale setting” message from Bazaar on Mac OS X

Adding following lines:

export LANG='en_US.UTF-8'
export LC_COLLATE='en_US.UTF-8'

to ~/.bash_profile seems to solve the problem (you will need to relaunch Terminal app or source the file). en_US can be replaced with your own locale, like ru_RU, just make sure it exists on Mac.

If you still get the error try unchecking "Set locale environment variables on startup" in Terminal.app

Preferences > Settings > Advanced > Set locale environment variables on startup

This worked for me on OS X Lion with Bazaar installed from homebrew.

Social comments Cackle